AutoSupport manifest is reporting collection of files as truncated or skipped in ONTAP 9
Applies to
- ONTAP 9
- AutoSupport
Issue
- In certain scenarios, AutoSupport data can be truncated during collection or during transmission (delivery).
- Truncation can occur if the content is too large to fit within the size budget constraints for specific AutoSupport subsystems or within the overall AutoSupport payload size during transmission
- Truncation can potentially hinder proactive and reactive support capabilities if certain content in an AutoSupport message is found to be missing.
Cause
- The collection of data for an AutoSupport subsystem has surpassed the allotted time or size limit set per your ONTAP version
- Each subsystem within ONTAP contributes to the overall collection of AutoSupport content
- To ensure AutoSupport's data collection is optimal and efficient, each subsystem has a collection size and time budget to prevent any one subsystem from spending too much time on any one log or file.
- The overall AutoSupport message delivery size has exceeded the maximum size for the transport method being used (SMTP or HTTPS)
- The default SMTP delivery size budget is 5 MB
- The default HTTPS delivery size budget is 50 MB
Solution
How to determine which AutoSupport data is being truncated
- Run the system node autosupport manifest show command for a full list of affected files due to truncation:
::> autosupport manifest show -node * -status *-limit
AutoSupport Collected
Node Sequence Body Filename Size Status Error
--------- -------- -------------- ----------- --------- -----------
node-01 14
rdb_dump.txt 1KB collection-truncated-file-size-limit This log file's contents are truncated.
cluster_ha.xml 730KB collection-truncated-file-size-limit This log file's contents are truncated.
- To review a specific AutoSupport message, specify the message's sequence number:
::> autosupport manifest show -seq-num 14 -fields prio-num,body-file,subsys,status,error,size-collected -subsys mhost -node local
node seq-num prio-num subsys body-file size-collected status error
------- ------- -------- ------ ------------ -------------- ------------------------------- -----
node-01 14 39 mhost rdb_dump.txt 1KB collection-truncated-size-limit ""
node-01 14 40 mhost cluster_ha.xml 730B collection-truncated-size-limit ""
The manifest information of the AutoSupport message will include one of the following error collection codes:
collection-truncated-size-limit
collection-skipped-size-limit
collection-truncated-time-limit
collection-skipped-time-limit
delivery-skipped-size-limit
Expected behavior
- Some files (e.g. log files) have individual size budgets for AutoSupport collection.
- Review the Additional Information section to learn more about which logs are known to exceed the limit.
- If a file collection is truncated because of a file-specific limit, the manifest status for this condition is
collection-truncated-file-size-limit
.- This truncation is expected behavior and can be ignored.
- Budgets for specific files are hard-coded and not configurable.
- This truncation is expected behavior and can be ignored.
"delivery-skipped-size-limit" error
AutoSupport transport protocol is SMTP
- Change the AutoSupport transport to HTTPS (recommended by NetApp)
- If AutoSupport is currently configured to use SMTP as the transport, modify the -transport parameter (Protocol to Contact Support) to use HTTPS instead of SMTP.
- With the HTTPS transport protocol, the overall AutoSupport message size can be much larger (default: 50 MB) and the connection with NetApp is encrypted and secure.
- Ensure that outbound communication from the node-mgmt and cluster-mgmt LIFs can connect to TCP port 443 at the destination: support.netapp.com.
- If you have configured an HTTP proxy for your environment, confirm that the proxy is reachable, instead.
- If AutoSupport is currently configured to use SMTP as the transport, modify the -transport parameter (Protocol to Contact Support) to use HTTPS instead of SMTP.
- If the AutoSupport transport cannot be changed to HTTPS, increase the SMTP maximum size to a limit that is supported by your SMTP servers
AutoSupport transport protocol is HTTPS
- Delivery to support.netapp.com will typically succeed, but internal/partner AutoSupport messages might be truncated
- Note: AutoSupport messages are sent via email (SMTP) for any configured -to or -partner-address e-mail destination addresses.
- See: AutoSupport Notifyd log - Error adding <file>: Payload size needs to be increased
"collection-truncated-*" and "collection-skipped-*" errors
- Make note of the AutoSupport subsystems and data files that are affected
- If you consistently see subsystem content truncation, contact NetApp Support:
Additional Information
- How to manage ONTAP 9 AutoSupport subsystem size and time budgets
- How to set up or modify AutoSupport in ONTAP 9
- To learn more about AutoSupport, see TR-4444 - ONTAP AutoSupport and AutoSuport On Demand Configuration Guide.
Notes:
- Not all files will be truncated if the subsystem size limit is breached.
- Binary files (7z, tgz, tar) that exceed the subsystem limits are not truncated -- they are entirely skipped from the AutoSupport message.
- Only the ASCII files (text, XML) are truncated.
Specific AutoSupport subsystem considerations
-
splog_latest
- The following files might truncate due to file-specific size budgets, error:
collection-truncated-file-size-limit
:sp-latest-system-event-log.txt
sp-latest-syslog.txt
sp-latest-statistics.txt
sp-downcontroller-syslog.txt
sp-downcontroller-statistics.txt
- The following files might truncate due to file-specific size budgets, error:
- Example: the content
sp-latest-system-event-log.txt
is set to a maximum of 71,680 bytes in ONTAP.
-
log_files
- The following files are typically truncated due to file-specific budgets, i.e.
collection-truncated-file-size-limit
:command-history.gz
mgwd.gz
secd.gz
- These are logs that are constantly being updated and rotated.
- These logs are collected in daily MANAGEMENT LOG AutoSupports messages
- This is expected behavior.
- The logs in multiple AutoSupport messages can be viewed and filtered, if needed.
- The following files are typically truncated due to file-specific budgets, i.e.