Skip to main content
NetApp Knowledge Base

Element cluster UI not accepting login credentials

Views:
706
Visibility:
Public
Votes:
1
Category:
netapp-hci
Specialty:
hci
Last Updated:

Applies to

NetApp Element software

Issue

  • When accessing Cluster UI via FQDN, the login page says that username or password is incorrect
  • API calls use username and password without issue
  • Accessing the MVIP or per-node UI returns:

{"error":"An error occurred while trying to encrypt the provided data. Refer to the inner exception for more information."}

  • The sf-element-auth.info file mentions cMaxAuthConfigurationDBSize needs to be at least a certain size:

2022-03-03T04:02:48.035253Z solidfire10 element-auth[52498]: plugin_base.Exceptions.ServiceUnavailableException: The Element API command returned an API server error: Change API constant cMaxAuthConfigurationDBSize to be at least 21167 bytes

2022-03-03T04:02:48.036482Z solidfire10 element-auth[52498]: ---> Element.Core.Exceptions.ApiServerException: Change API constant cMaxAuthConfigurationDBSize to be at least 21167 bytes

Sign in to view the entire content of this KB article.

New to NetApp?

Learn more about our award-winning Support

NetApp provides no representations or warranties regarding the accuracy or reliability or serviceability of any information or recommendations provided in this publication or with respect to any results that may be obtained by the use of the information or observance of any recommendations provided herein. The information in this document is distributed AS IS and the use of this information or the implementation of any recommendations or techniques herein is a customer's responsibility and depends on the customer's ability to evaluate and integrate them into the customer's operational environment. This document and the information contained herein may be used solely in connection with the NetApp products discussed in this document.