Skip to main content
NetApp Knowledge Base

'HTTP 401: Error getting root assets' when running setup-mnode

Views:
777
Visibility:
Public
Votes:
2
Category:
element-software
Specialty:
hci
Last Updated:

Applies to

  • Management node (mNode)
  • Element software 11.3 and higher

Issue

When running the setup-mnode script (/sf/packages/mnode/setup-mnode), the following error appears:

HTTP 401: Error getting root assets 

Full error output:

2019-08-21T06:47:00.513774Z]:[config_util:75] INFO:Retrying 45/45 time...
[2019-08-21T06:47:00.514760Z]:[config_util:78] INFO:Waiting 10 seconds before next attempt.
[2019-08-21T06:47:10.577006Z]:[config_util:72] ERROR:Maximum Retry Attempts (45) Reached. Raising Error.
Traceback (most recent call last):
  File "setup_scripts/config_util.py", line 59, in retry_operation
  File "setup_scripts/mnode_api_client.py", line 32, in get_root_assets
  File "setup_scripts/mnode_api_client.py", line 343, in handle_response
sfprime.MnodeCfgError: Error: HTTP 401: Error getting root assets. -
[2019-08-21T06:47:10.577901Z]:[mnodecfg:69] ERROR:Error: HTTP 401: Error getting root assets. -

 

Sign in to view the entire content of this KB article.

New to NetApp?

Learn more about our award-winning Support

NetApp provides no representations or warranties regarding the accuracy or reliability or serviceability of any information or recommendations provided in this publication or with respect to any results that may be obtained by the use of the information or observance of any recommendations provided herein. The information in this document is distributed AS IS and the use of this information or the implementation of any recommendations or techniques herein is a customer's responsibility and depends on the customer's ability to evaluate and integrate them into the customer's operational environment. This document and the information contained herein may be used solely in connection with the NetApp products discussed in this document.