Skip to main content
NetApp Knowledge Base

Element Plug-In for VMware returns "Server error" after registration

Views:
175
Visibility:
Public
Votes:
0
Category:
netapp-hci
Specialty:
hci
Last Updated:

Applies to

  • NetApp hyperconverged infrastructure (HCI)
  • NetApp Element Plug-In for VMware vCenter Server 5.0
  • VMware vCenter 7.0.x
  • Non-HCI compute nodes mixed in the same vCenter cluster with HCI compute nodes
  • Customer defined NetApp Hybrid Cloud Control (HCC) user for vCenter

Issue

  • After what appears a successfull registration of the plug-in, a blue banner appears in vCenter
    Server error. Please try again or Contact NetApp support.
     
  • When verifying the credentials for the HCC user on the REST API /controllers/{controller_id}, the response code contains 
    "statusReason": loginFailed,
     
  • The mnode_vcenter container logs show
    ERROR: Authentication error occurred : Unable to connect to vCenter <vCenter_IP> due to invalid credentials.
  • Login with the known credentials for the HCC user into vCenter does work

Sign in to view the entire content of this KB article.

New to NetApp?

Learn more about our award-winning Support

NetApp provides no representations or warranties regarding the accuracy or reliability or serviceability of any information or recommendations provided in this publication or with respect to any results that may be obtained by the use of the information or observance of any recommendations provided herein. The information in this document is distributed AS IS and the use of this information or the implementation of any recommendations or techniques herein is a customer's responsibility and depends on the customer's ability to evaluate and integrate them into the customer's operational environment. This document and the information contained herein may be used solely in connection with the NetApp products discussed in this document.