Skip to main content

NetApp wins prestigious Coveo Relevance Pinnacle Award. Learn more!

NetApp Knowledge Base

vCenter plug-in deployment fails after upgrading vCenter to version 7.0 U3

Views:
3,946
Visibility:
Public
Votes:
4
Category:
element-plug-in-for-vcenter-server
Specialty:
hci
Last Updated:

Applies to

  • NetApp Element Plug-in for vCenter Server (up to 4.10.0)
  • VMware vCenter version 7.0 U3 - 7.0 U3h

Issue

  • After upgrading the vCenter server to version 7.0 U3, Element Plug-in for vCenter Server fails to deploy
  • Error example:
    • com.vmware.vise.core.model.exception.CompositeException: CompositeException java.lang.reflect.InvocationTargetException java.lang.Exception: org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'org.springframework.web.servlet.mvc.method.annotation.RequestMappingHandlerMapping': Invocation of init method failed; nested exception is org.springframework.beans.factory.CannotLoadBeanClassException: Cannot find class [org.springframework.web.servlet.mvc.annotation.AnnotationMethodHandlerAdapter] for bean with name 'org.springframework.web.servlet.mvc.annotation.AnnotationMethodHandlerAdapter#0' defined in URL [bundleentry://410.fwk1004908647/WEB-...ntextRest.xml]; nested exception is java.lang.ClassNotFoundException: org.springframework.web.servlet.mvc.annotation.AnnotationMethodHandlerAdapter cannot be found by com.solidfire.vcp.solidfire-war_4.7.0 Related cause: org.springframework.beans.factory.CannotLoadBeanClassException: Cannot find class [org.springframework.web.servlet.mvc.annotation.AnnotationMethodHandlerAdapter] for bean with name 'org.springframework.web.servlet.mvc.annotation.AnnotationMethodHandlerAdapter#0' defined in URL [bundleentry://410.fwk1004908647/WEB-...ntextRest.xml]; nested exception is java.lang.ClassNotFoundException: org.springframework.web.servlet.mvc.annotation.AnnotationMethodHandlerAdapter cannot be found by com.solidfire.vcp.solidfire-war_4.7.0 com.vmware.vise.extensionfw.impl.OsgiBundleDeployer.throwIfNeeded(OsgiBundleDeployer.java:346) com.vmware.vise.extensionfw.impl.OsgiBundleDeployer.deploySubsystem(OsgiBundleDeployer.java:494) com.vmware.vise.extensionfw.impl.OsgiBundleDeployer.deploy(OsgiBundleDeployer.java:96) com.vmware.vise.extensionfw.impl.PackagesDeployer.deployInternalPlugin(PackagesDeployer.java:614) com.vmware.vise.extensionfw.impl.PackagesDeployer.deployPlugin(PackagesDeployer.java:565) com.vmware.vise.extensionfw.impl.PackagesDeployer.access$100(PackagesDeployer.java:52) com.vmware.vise.extensionfw.impl.PackagesDeployer$PackageDeployTask.call(PackagesDeployer.java:547) com.vmware.vise.extensionfw.impl.PackagesDeployer$PackageDeployTask.call(PackagesDeployer.java:536) java.util.concurrent.FutureTask.run(FutureTask.java:266) java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) java.util.concurrent.FutureTask.run(FutureTask.java:266) java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) java.lang.Thread.run(Thread.java:748)
       
  • HTTP Status 500 – Internal Server Error the message might be seen
     
  • Alternative error:
    Error deploying plug-in. org.apache.felix.resolver.reason.ReasonException: Unable to resolve /usr/lib/vmware-vsphere-ui/server/work/tmp/4620870904457411146com.solidfire-4.9.0.0.esa/solidfire-dataservice-4.9.0.jar: missing requirement org.apache.aries.subsystem.core.archive.ImportPackageRequirement: namespace=osgi.wiring.package, attributes={}, directives={filter=(&(osgi.wiring.package=org.springframework.orm.hibernate4)(version>=0.0.0)), resolution=mandatory}, resource=/usr/lib/vmware-vsphere-ui/server/work/tmp/4620870904457411146com.solidfire-4.9.0.0.esa/solidfire-dataservice-4.9.0.jar org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1340)

Sign in to view the entire content of this KB article.

New to NetApp?

Learn more about our award-winning Support

Scan to view the article on your device