Skip to main content
NetApp Response to Russia-Ukraine Cyber Threat
In response to the recent rise in cyber threat due to the Russian-Ukraine crisis, NetApp is actively monitoring the global security intelligence and updating our cybersecurity measures. We follow U.S. Federal Government guidance and remain on high alert. Customers are encouraged to monitor the Cybersecurity and Infrastructure Security (CISA) website for new information as it develops and remain on high alert.
NetApp Knowledge Base

'HTTP 401: Error getting root assets' when running setup-mnode

Views:
635
Visibility:
Public
Votes:
0
Category:
element-software
Specialty:
hci
Last Updated:

Applies to

  • Management node (mNode)
  • Element 11.3 and higher

Issue

When running the setup-mnode script (/sf/packages/mnode/setup-mnode), the following error appears:

HTTP 401: Error getting root assets 

Full error output:

2019-08-21T06:47:00.513774Z]:[config_util:75] INFO:Retrying 45/45 time...
[2019-08-21T06:47:00.514760Z]:[config_util:78] INFO:Waiting 10 seconds before next attempt.
[2019-08-21T06:47:10.577006Z]:[config_util:72] ERROR:Maximum Retry Attempts (45) Reached. Raising Error.
Traceback (most recent call last):
  File "setup_scripts/config_util.py", line 59, in retry_operation
  File "setup_scripts/mnode_api_client.py", line 32, in get_root_assets
  File "setup_scripts/mnode_api_client.py", line 343, in handle_response
sfprime.MnodeCfgError: Error: HTTP 401: Error getting root assets. -
[2019-08-21T06:47:10.577901Z]:[mnodecfg:69] ERROR:Error: HTTP 401: Error getting root assets. -

 

Scan to view the article on your device
CUSTOMER EXCLUSIVE CONTENT

Registered NetApp customers get unlimited access to our dynamic Knowledge Base.

New authoritative content is published and updated each day by our team of experts.

Current Customer or Partner?

Sign In for unlimited access

New to NetApp?

Learn more about our award-winning Support