Skip to main content
NetApp Knowledge Base

Unable to view the ESXi hosts from the ONTAP select deploy

Views:
417
Visibility:
Public
Votes:
0
Category:
ontap-select
Specialty:
ontapselect
Last Updated:

Applies to

ONTAP select deploy

Issue

In the ONTAP Select Deploy webpage Hypervisor Hosts tab, the hosts fail to load. Instead, the tab reports the error below:

Invalid Output: [] is not of type 'object' Failed validating 'type' in schema['properties']['records']['items']['properties']['hardware_config']: {'additionalProperties': False, 'properties': {'cores_in_use': {'type': 'integer'}, 'cpu_arch': {'type': 'string'}, 'cpu_model': {'type': 'string'}, 'cpu_speed_mhz': {'type': 'integer'}, 'cpu_vendor': {'type': 'string'}, 'hardware_model': {'type': 'string'}, 'hardware_vendor': {'type': 'string'}, 'mem_size': {'type': 'integer'}, 'mem_usage': {'type': 'integer'}, 'node_free_memory': {'items': {'properties': {'Node0 free memory': {'type': 'string'}, 'Node1 free memory': {'type': 'string'}}, 'type': 'object', 'x-scope': ['', '#/definitions/autosupport_response', '#/definitions/autosupport', '#/definitions/cluster', '#/definitions/node', '#/definitions/host', '#/definitions/host_hardware_config']}, 'type': 'array'}, 'num_cpu_cores': {'type': 'integer'}, 'num_hbas': {'type': 'integer'}, 'num_nics': {'type': 'integer'}, 'number_cpu_cores_socket': {'type': 'integer'}, 'number_cpu_sockets': {'type': 'integer'}, 'number_cpu_threads_core': {'type': 'integer'}, 'number_cpus': {'type': 'integer'}, 'number_of_numa_nodes': {'type': 'string'}, 'power_management': {'type': 'string'}, 'product_version': {'type': 'string'}, 'smbios_block': {'items': {'properties': {'date': {'type': 'string'}, 'release': {'type': 'string'}, 'vendor': {'type': 'string'}, 'version': {'type': 'string'}}, 'type': 'object', 'x-scope': ['', '#/definitions/autosupport_response', '#/definitions/autosupport', '#/definitions/cluster', '#/definitions/node', '#/definitions/host', '#/definitions/host_hardware_config']}, 'type': 'array'}, 'uuid': {'type': 'string'}}, 'type': 'object', 'x-scope': ['', '#/definitions/autosupport_response', '#/definitions/autosupport', '#/definitions/cluster', '#/definitions/node', '#/definitions/host']} On instance['records'][103]['hardware_config']: [].

 

host

You may see similar errors and/or missing hosts when you attempt to create a new cluster.

 

Sign in to view the entire content of this KB article.

New to NetApp?

Learn more about our award-winning Support

NetApp provides no representations or warranties regarding the accuracy or reliability or serviceability of any information or recommendations provided in this publication or with respect to any results that may be obtained by the use of the information or observance of any recommendations provided herein. The information in this document is distributed AS IS and the use of this information or the implementation of any recommendations or techniques herein is a customer's responsibility and depends on the customer's ability to evaluate and integrate them into the customer's operational environment. This document and the information contained herein may be used solely in connection with the NetApp products discussed in this document.