Skip to main content
NetApp Knowledge Base

API for lifecycle configuration on S3 bucket fails by HTTP 400

Views:
89
Visibility:
Public
Votes:
1
Category:
storagegrid
Specialty:
sgrid
Last Updated:

Applies to

StorageGRID 11.4

Issue

API for lifecycle configuration on S3 bucket fails by HTTP 400 when Rule contains neither Filter or Prefix element.

Result Code : 400
The XML you provided was not well-formed.

 

Example:

<LifecycleConfiguration>
  <Rule>
    <ID>rule1</ID>
    <Expiration>
      <Days>30</Days>
    </Expiration>
    <Status>Enabled</Status>
  </Rule>
</LifecycleConfiguration>

 

 

Sign in to view the entire content of this KB article.

New to NetApp?

Learn more about our award-winning Support

NetApp provides no representations or warranties regarding the accuracy or reliability or serviceability of any information or recommendations provided in this publication or with respect to any results that may be obtained by the use of the information or observance of any recommendations provided herein. The information in this document is distributed AS IS and the use of this information or the implementation of any recommendations or techniques herein is a customer's responsibility and depends on the customer's ability to evaluate and integrate them into the customer's operational environment. This document and the information contained herein may be used solely in connection with the NetApp products discussed in this document.
Scan to view the article on your device