CSG-27787: Heavy delete workload causes high S3 latency and HTTP 500 errors on StorageGRID
Issue
- S3 read and write latency increases under heavy delete workload
- S3 requests fail with HTTP 500
Internal Server Error
Note: A storage node offlined for several days can receive a heavier delete load after it returns
