CSNAPC-12166: SCC 6.x DB2 : DB2 complete discovery fails with IndexOutOfBoundsException and SCC-00175 [null] when hostname is empty
Issue
The following java exception is seen in the DB2_[JOB].log during discovery:com.netapp.plugincreator.workflow.task.AppCompleteDiscoveryTask -Index 0 out of bounds for length 0
java.lang.IndexOutOfBoundsException: Index 0 out of bounds for length 0
at java.base/jdk.internal.util.Preconditions.outOfBounds(Preconditions.java:64)
at java.base/jdk.internal.util.Preconditions.outOfBoundsCheckIndex(Preconditions.java:70)
at java.base/jdk.internal.util.Preconditions.checkIndex(Preconditions.java:266)
at java.base/java.util.Objects.checkIndex(Objects.java:361)
at java.base/java.util.ArrayList.get(ArrayList.java:427)
