Skip to main content
NetApp Response to Russia-Ukraine Cyber Threat
In response to the recent rise in cyber threat due to the Russian-Ukraine crisis, NetApp is actively monitoring the global security intelligence and updating our cybersecurity measures. We follow U.S. Federal Government guidance and remain on high alert. Customers are encouraged to monitor the Cybersecurity and Infrastructure Security (CISA) website for new information as it develops and remain on high alert.
NetApp Knowledge Base

What is the upgrade matrix for storage clusters running NetApp Element software?

Views:
3,979
Visibility:
Public
Votes:
2
Category:
element-software
Specialty:
solidfire
Last Updated:

 

Applies to

  • NetApp SolidFire All Flash Arrays 
  • NetApp SolidFire Cluster Performance 
  • NetApp Element software 

Answer

This article provides information about the NetApp Element software upgrade versions and paths.

Note: Always install and use the latest version of HealthTools to upgrade the Element version on your storage cluster. For the detailed upgrade procedure, see here

This table shows the supported upgrade paths for Element. Find the version that your storage cluster is currently running in the first column to know the target Element versions the cluster can be upgraded to. 

This table is applicable to all NetApp HCI and AFA storage platforms, unless noted otherwise. Any Element version that is not shown in this table may be unsupported or may be in Limited Support period and would need assistance from NetApp Support to perform the upgrade.

Reminder: Always install and use the latest HealthTools or Hybrid Cloud Control to upgrade Element version on your storage cluster. For detailed upgrade procedure, refer to the Element User Guide

Important: 

 

Starting Element cluster version

Upgrade your storage cluster to these Element versions using Management Node 10.x

Note: In case an upgrade is supported with both 10.x and 11.x Management Nodes, always use the 11.x Management Node.

Upgrade your storage cluster to these Element versions using Management Node 11.x

Note: Management Node 11.3+ requires Element 11.3+ on the storage cluster to support the new management node architecture.
9.0* 9.5.1, 10.1, 10.4.x†^, 10.5.x†^, 10.6.x†^ 10.4.x†^, 10.5.x†^, 10.6.x†^
9.1* 9.5.1, 10.1, 10.4.x†^, 10.5.x†^, 10.6.x†^ 10.4.x†^, 10.5.x†^, 10.6.x†^
9.2.0* 9.5.1, 10.1, 10.4.x†^, 10.5.x†^, 10.6.x†^ 10.4.x†^, 10.5.x†^, 10.6.x†^
9.2.1* 9.5.1, 10.1, 10.4.x†^, 10.5.x†^, 10.6.x†^ 10.4.x†^, 10.5.x†^, 10.6.x†^
9.3 9.5.1, 10.1, 10.4.x†^, 10.5.x†^, 10.6.x†^ 10.4.x†^, 10.5.x†^, 10.6.x†^
9.4 9.5.1, 10.1, 10.4.x†^, 10.5.x†^, 10.6.x†^ 10.4.x†^, 10.5.x†^, 10.6.x†^
9.5.0 9.5.1, 10.4.x†^, 10.5.x†^, 10.6.x†^ 10.4, 10.5, 10.6
9.5.1 10.4.1, 10.4.2†^, 10.5.x†^, 10.6.x†^ 10.4.1, 10.4.2†^, 10.5.x†^, 10.6.x†^
10.0 10.1, 10.4.x†^, 10.5.x†^, 10.6.x†^ 10.4.x†^, 10.5.x†^, 10.6.x†^, 11.0.x†^, 11.1.x^, 11.3P1, 11.3.2, 11.5.x^, 11.7, 11.8.x^
10.1 10.4.x†^, 10.5.x†^, 10.6.x†^ 10.4.x†^, 10.5.x†^, 10.6.x†^, 11.0.x†^, 11.1.x^, 11.3P1, 11.3.2, 11.5.x^, 11.7, 11.8.x^
10.2 10.3.0, 10.3.1,10.4.x†^, 10.5.x†^, 10.6.x†^ 10.3.1, 10.4.x†^, 10.5.x†^, 10.6.x†^, 11.0.x†^, 11.1.x^, 11.3P1, 11.3.2, 11.5.x^, 11.7, 11.8.x^
10.3.0 10.3.1,10.4.x†^, 10.5.x†^, 10.6.x†^ 10.3.1, 10.4.x†^, 10.5.x†^, 10.6.x†^, 11.0.x†^, 11.1.x^, 11.3P1, 11.3.2, 11.5.x^, 11.7, 11.8.x^
10.3.1 10.4.1,10.4.2†, 10.5.x†^, 10.6.x†^ 10.4.1, 10.4.2, 10.5.1, 10.6.1, 11.1.x^, 11.3P1, 11.3.2, 11.5.x^, 11.7, 11.8.x^
10.4.0 10.4.1, 10.4.2, 10.5†^, 10.6†^ 10.4.1, 10.4.2, 10.5, 10.6, 11.0, 11.1.x^, 11.3P1, 11.3.2, 11.5.x^, 11.7, 11.8.x^
10.4.1 10.4.2, 10.5.1, 10.6 10.4.2, 10.5.x^, 10.6.x†^, 11.1.x^, 11.3P1, 11.3.2, 11.5.x^, 11.7, 11.8.x^
10.4.2 10.5.1, 10.6.1  10.5.1, 10.6.1, 11.1.1^, 11.3.2, 11.5.x, 11.7, 11.8.x^
10.5.0 10.5.1, 10.6.x†^ 10.5.1, 10.6.x†^, 11.1.1^, 11.3P1, 11.3.2, 11.5.x^, 11.7, 11.8.x^
10.5.1 10.6.1 10.6.1, 11.1.1^, 11.3P1, 11.3.2, 11.5.x^, 11.7, 11.8.x^
10.6 10.6.1 10.6.1, 11.3.1, 11.3.2, 11.5.x^, 11.7, 11.8.x^
10.6.1   11.3.2, 11.5.x^, 11.7, 11.8.x^
11.0.0   11.0.2†, 11.1.x^, 11.3P1, 11.3.2, 11.5.x^, 11.7, 11.8.x^, 12.0, 12.2, 12.3
11.0.2   11.1.1^, 11.3.2, 11.5.x^, 11.7, 11.8.x^, 12.0, 12.2, 12.3
11.1.0   11.1.x^, 11.3P1, 11.3.2, 11.5.x^, 11.7, 11.8.x^ , 12.0, 12.2, 12.3
11.1.1   11.3.2, 11.5.x^, 11.7, 11.8.x^, 12.0, 12.2, 12.3
11.3.0   11.3P1, 11.3.2, 11.5.x^, 11.7, 11.8.x^, 12.x^
11.3.1 (11.3P1)   11.3.2, 11.5.x^, 11.7, 11.8.x^, 12.x^
11.3.2   11.5.x^, 11.7, 11.8.x^, 12.x^
11.5.0   11.5.1, 11.7, 11.8.x^, 12.x^
11.5.1   11.7, 11.8.x^, 12.x^
11.7   11.8.x^, 12.x^
11.8   11.8.1+^ , 12.x^
11.8.1   11.8.2, 12.0.1, 12.2.1, 12.3.x^, 12.5
11.8.2   12.5
12.0   12.0.1, 12.2, 12.2.1, 12.3.x^, 12.5
12.0.1   12.2.1, 12.3.x^, 12.5
12.2   12.2.1, 12.3.x^, 12.5
12.2.1   12.3.x^, 12.5
12.3   12.3.x^, 12.5
12.3.1   12.3.2+, 12.5
12.3.2   12.5

Notes:

*: Pre-upgrade Healthchecks are supported starting with Element 9.3. 

: Fibre-channel nodes FC0025 and FCN001 are not supported with these Element versions.

^: In instances where we use .x, it indicates all . versions of the release. For example, 10.x includes all versions of Element 10.0, that is, 10.1, 10.2, and so on.

^: In instances where we use +, it indicates all . versions of the release after the stated patch. For example, 10.4.1+ includes all versions of Element 10.4.1, 10.4.2, and beyond, but not 10.4.0.

Additional Information

N/A

 

Scan to view the article on your device