Skip to main content
NetApp Knowledge Base

setup-mnode script on mNode failing with error: Failed to establish a new connection: Errno 111 Connection refused

Views:
623
Visibility:
Public
Votes:
0
Category:
element-software
Specialty:
solidfire
Last Updated:

Applies to

  • 11.x mNode
  • 12.x mNode

Issue

setup-mnode script fails to run with the following error:

mNodeCLI # /sf/packages/mnode/setup-mnode --mnode_admin_user [username] --storage_mvip [mvip] --storage_username [username] --telemetry_active [true]

sfprime.MnodeCfgError: Unknown Error: Failed to either retrieve cluster version, or validate cluster credentials.
HTTPSConnectionPool(host='X.X.X.X', port=442): Max retries exceeded with url: /json-rpc/10.0 (Caused by NewConnectionError('<urllib3.connection.VerifiedHTTPSConnection object at 0x7f5ac9a20ef0>: Failed to establish a new connection: [Errno 111] Connection refused',))

 

 

 

Sign in to view the entire content of this KB article.

New to NetApp?

Learn more about our award-winning Support

NetApp provides no representations or warranties regarding the accuracy or reliability or serviceability of any information or recommendations provided in this publication or with respect to any results that may be obtained by the use of the information or observance of any recommendations provided herein. The information in this document is distributed AS IS and the use of this information or the implementation of any recommendations or techniques herein is a customer's responsibility and depends on the customer's ability to evaluate and integrate them into the customer's operational environment. This document and the information contained herein may be used solely in connection with the NetApp products discussed in this document.