Skip to main content
NetApp Knowledge Base

Unable to mount NFS Volume due to asymmetric routing

Views:
Visibility:
Public
Votes:
0
Category:
ontap-9
Specialty:
nas
Last Updated:

Applies to

  • NetApp ONTAP (including 9.14.1P9 and similar)
  • NFS protocol (NFSv3/v4)
  • Environments with network firewalls between ONTAP and VM clients

Issue

Kubernetes pods were unable to mount NFS volumes hosted on NetApp ONTAP storage. The following symptoms and logs were observed:

  • Mount attempts from Linux clients succeeded, but mounting from Kubernetes pods failed with connection timed out.
  • Packet trace showed client traffic entering ONTAP on one interface (e.g., e8b-687) but reply traffic egressing on another (e.g., a0a) via the default gateway.
  • ONTAP export-policy check showed correct permissions for the client IP
  • Packet trace summary: Asymmetric routing detected – client connections arriving on e.g., e8b-687, reply traffic egressing via a0a (default gateway), causing firewall drops.

Sign in to view the entire content of this KB article.

New to NetApp?

Learn more about our award-winning Support

NetApp provides no representations or warranties regarding the accuracy or reliability or serviceability of any information or recommendations provided in this publication or with respect to any results that may be obtained by the use of the information or observance of any recommendations provided herein. The information in this document is distributed AS IS and the use of this information or the implementation of any recommendations or techniques herein is a customer's responsibility and depends on the customer's ability to evaluate and integrate them into the customer's operational environment. This document and the information contained herein may be used solely in connection with the NetApp products discussed in this document.