Intermittent “km.keyserver.not.available” alerts
Applies to
- ONTAP 9
- AFF/ASA/FAS
-
Environments using External KMIP key servers for encryption
Issue
- ONTAP periodically reports the following errors and the error is getting cleared after 15 minutes.
- EMS Logs:
[Cluster-01: mgwd: km.keyserver.notavailable:alert]: The external key management server "100.00.00.49:5696" is not available for Vserver "svm1", status: "not-responding".[Cluster-01: mgwd: km.keyserver.available:notice]: The external key management server "vserver: svm1, keyServer: 100.00.00.49:5696" is now available for Vserver "svm1
- mgwd logs:
[kern_mgwd:info:3758] WARNING: keymanager_mgwd::health::kmip::KmsHealthHandler:[checkHealth]:209: Keyserver 'vserver:sm1,keyServer:100.00.00.49:5696' on vserver svm1 status is not-responding; failurecount:0
- KMIP Client Logs:
[kern_kmip2_client:info:8993] [May 18 03:17:54]: 0x80a606c00: 0: ERR: kmip2::kmipCmds::KmipConnection: [cryptsoftErrorCb]:95: Error: src/kmip_io.c: 403: error: 10: msg: KMIP_xmit:KMIP_recv[kern_kmip2_client:info:8993] [May 18 03:17:54]: 0x80a606c00: 0: ERR: kmip2::kmipCmds::KmipConnection: [cryptsoftErrorCb]:95: Error: src/kmip_cmd.c: 2674: error: 10: msg: KMIP_CMD_xmit:KMIP_xmit
- Alerts typically fire during health check interval and clears automatically.
