AutoSupport delivery fails due to DNS - Couldn't resolve host in ONTAP 9 and earlier
Applies to
- AutoSupport
- ONTAP 9
- SMTP
- HTTP(s)
Issue
Nodes could not connect to the DNS servers and could not resolve any of the following host names.
- Support.netapp.com
- your mailhost server (if using SMTP)
- your proxy server (if configured)
Verify: (3 options)
- Run command
Autosupport history show
::>system autosupport history show
::>system autosupport history show -node <node_name> -fields node,seq-num,status,error,destination
Last Error reported :
Couldn't resolve host name.
- Testing connectivity from the command line
::> set advanced
::> system node autosupport check show-details -node node_name
::> vserver services name-service dns check -vserver <name>
Example:
Category: smtp
Component: mail-server
Status: failed
Detail: SMTP connectivity check failed for destination:
mailhost. Error: Could not resolve host - 'mailhost'
Corrective Action: Check the hostname of the SMTP server
::> vserver name-service dns check -vserver netappfas01
Name Server
Vserver Name Server Status Status Details
------------- --------------- ------------ --------------------------
netappfas01 10.15.5.10 down Connection refused.
netappfas01 172.12.191.114 down Operation timed out.
2 entries were displayed.
- Review the notifyd logs.
::> node run -node (node-name) -command rdfile /etc/log/mlog/notifyd.log
Notified logs display the following errors:
Attempting to deliver ASUP using PUT)
0000001b.000723c6 04233027 Fri Feb 27 2015 02:27:01 -05:00 [kern_notifyd:info:829] (category:
829:1528:deliver) (emittime: 2/27/2015 02:27:01) (message: getaddrinfo(3) failed for
support.netapp.com:443)
0000001b.000723c7 04233027 Fri Feb 27 2015 02:27:01 -05:00 [kern_notifyd:info:829] (category:
829:1528:deliver) (emittime: 2/27/2015 02:27:01) (message: Couldn't resolve host
'support.netapp.com')
0000001b.000723c8 04233027 Fri Feb 27 2015 02:27:01 -05:00 [kern_notifyd:info:829] (category:
829:1528:deliver) (emittime: 2/27/2015 02:27:01) (message: Closing connection #0)
ERR: AutoSupport::StatusCheck:Connectivity check to HTTP PUT destination failed (Couldn't resolve host name) with root CA path: /mroot/etc/vserver_4294967295/certificates/ssl/serverCa
Cause
There can be various causes that would prevent connectivity to your DNS servers:
- Verify you have proper routing to the DNS
- If using port e0m , make sure its in the same subnet as the SP/BMC . Can the SP / BMC and e0M interface be configured on different subnets?
- Potential traffic going out of your Intercluster lif due to Behavior in Bug 952014 - AutoSupport traffic disrupts when the storage system selects intercluster LIFs for outbound traffic
-
Management lifs are blocked by a firewall
Solution
Option 1 Perform the following steps to review your DNS server
- Verify if you have a route to the DNS server (work with your network team)
Validate the status of the name servers.
::>vserver services name-service dns check -vserver vs1
Vserver Name Server Status Status Details
------- ----------- ------ -----------------------
vs1 10.0.0.50 up Response time (msec): 2
vs1 10.0.0.51 up Response time (msec): 2
- Edit the DNS services to add a different DNS server Configure DNS for host-name resolution
Option 2 Review your Firewall policies
- Allow / trust the mgmt IP's (Cluster management and node management lifs) on the Firewall
-
To determine which IPs need to be Allowed:
Cluster::> network interface show -role *mgmt*
Logical Status Network Current Current Is
Vserver Interface Admin/Oper Address/Mask Node Port Home
----------- ---------- ---------- ------------------ ------------- ------- ----
Cluster
Node1_mgmt1 up/up 10.61.64.38/24 Node1 e0M true
Node2_mgmt1 up/up 10.61.64.40/24 Node1 e0M true
cluster_mgmt up/up 10.61.64.42/24 Node1 e0e true
Option 3 change AutoSupport destination to IP (SMTP Only)
If option 1 is not possible or as a Temporary fix, you may change the email host from the email hostname to IP address in ONTAP
::> system node autosupport show
::> autosupport modify -node * -mail-hosts <ip address>
Option 4 create a host entry to resolve the hostname
The following procedure will add a host entry in ONTAP to allow Name resolution and bypass connecting to your DNS server.
Note: This is a temporary fix. You should work with your network team to determine why the Node cannot communicate with the DNS servers.
- Add a Host entry to resolve
'support.netapp.com'
manually to 216.240.21.18.
::> vserver services dns hosts create -vserver node1 -address 216.240.21.18 -hostname support.netapp.com
Note: You can add similar entries to manually resolve your proxy or mailhost hostnames
Additional Information
- AutoSupport not working over SMTP - error message: FTP: weird server reply
- Configure DNS for host-name resolution
- How to use DNS check command to diagnose issues with name servers
- See TR-4444 and ONTAP 9 Documentation for Autosupport configuration and networking requirements.
- Use the following commands to edit DNS server as needed:
vserver services name-service dns show - Display DNS configuration
vserver services name-service dns create - Create a new DNS table entry
vserver services name-service dns modify - Change a DNS table entry
vserver services name-service dns delete - Remove a DNS table entry
- Use the following commands to edit DNS host as needed:
vserver services dns hosts create - Create a new host table entry
vserver services dns hosts delete - Remove a host table entry
vserver services dns hosts modify - Modify hostname or aliases
vserver services dns hosts show - Display IP address to hostname mappings