SnapCenter upgrade failure - SnapCenter Schema Creation
Applies to
- SnapCenter Server 6.0, 6.0.1 and 6.2.2
- Microsoft .NET Windows Server Hosting Bundle
Issue
- SnapCenter upgrade fails with error:
ERROR: SnapCenter Schema Creation failed. Check the DotMigrate logs in the Windows Temp folder for more details.
- The corresponding
DotMigratelogs referenced in the error (SC_DotMigrate_*) are not present in the Windows Temp folder. - The
SMS_Upgrade_<date_time>.logcontains:CreateDB: CustomAction1: Call dotMigrate C:\Users\<user_account>\AppData\Local\Temp\ruc3ep43.3m5\dotMigrate.exe
CreateDB: CustomAction1: With commandline -i -v -r -s "C:\Users\<user_account>\AppData\Local\Temp\ruc3ep43.3m5\2.0" -h localhost -y 3306 -l C:\Users\<user_account>\AppData\Local\Temp\SC_DotMigrate_MySQL_v2.0_<date_time>.log -d nsm -x MySqlConnector
CreateDB: CustomAction1: dotMigrate Exitcode -2147450730
CreateDB: CustomAction1: Error!!!! dotMigrate return with failure
ERROR: SnapCenter Schema Creation failed. Check the DotMigrate logs in the Windows Temp folder for more details.
