Skip to main content
NetApp Knowledge Base

SnapCenter upgrade failure - SnapCenter Schema Creation

Views:
545
Visibility:
Public
Votes:
0
Category:
snapcenter
Specialty:
snapx
Last Updated:

Applies to

  • SnapCenter Server 6.0, 6.0.1 and 6.2.2
  • Microsoft .NET Windows Server Hosting Bundle

Issue

  • SnapCenter upgrade fails with error:

ERROR: SnapCenter Schema Creation failed.  Check the DotMigrate logs in the Windows Temp folder for more details.snapcenter schema creation failed.png

  • The corresponding DotMigrate logs referenced in the error (SC_DotMigrate_*) are not present in the Windows Temp folder.
  • The SMS_Upgrade_<date_time>.log contains:
    CreateDB: CustomAction1: Call dotMigrate C:\Users\<user_account>\AppData\Local\Temp\ruc3ep43.3m5\dotMigrate.exe
    CreateDB: CustomAction1: With commandline  -i -v -r -s "C:\Users\<user_account>\AppData\Local\Temp\ruc3ep43.3m5\2.0" -h localhost -y 3306 -l C:\Users\<user_account>\AppData\Local\Temp\SC_DotMigrate_MySQL_v2.0_<date_time>.log -d nsm -x MySqlConnector
    CreateDB: CustomAction1: dotMigrate Exitcode  -2147450730
    CreateDB: CustomAction1: Error!!!! dotMigrate return with failure
    ERROR: SnapCenter Schema Creation failed. Check the DotMigrate logs in the Windows Temp folder for more details.

Sign in to view the entire content of this KB article.

New to NetApp?

Learn more about our award-winning Support

NetApp provides no representations or warranties regarding the accuracy or reliability or serviceability of any information or recommendations provided in this publication or with respect to any results that may be obtained by the use of the information or observance of any recommendations provided herein. The information in this document is distributed AS IS and the use of this information or the implementation of any recommendations or techniques herein is a customer's responsibility and depends on the customer's ability to evaluate and integrate them into the customer's operational environment. This document and the information contained herein may be used solely in connection with the NetApp products discussed in this document.