CSNAPC-11749: SCC Windows: Plugin Creator service startup failure when system locale set to German
Issue
- After upgrading to SnapCenter 6.2.2, the SnapCenter Plug-in Creator service (PluginCreatorService) on Windows plug-in hosts fails to start or reports misleading success, while SCC agent is dead.
- Errors seen in plug-in host logs:
- SCAgentService.log
- [Error] SCAgentWindowsService.SCAgentWorker: Service startup failed: Service startup failed: Aug. 18, 2026 1:52:17 PM org.apache.cxf.endpoint.ServerImpl initDestination
- SC-Core.log
- ERROR [main] 119 com.netapp.plugincreator.agent.nextgen.Starter -SCC-ENG-00166: Port [9090] is already in use. Trying for next available port.
- ERROR [main] 119 com.netapp.plugincreator.common.util.PortHelper -SCC-ENG-00159: Registry for SCC Port [58351] not found, exiting and stopping Plug-in Creator service now.
