Skip to main content
NetApp Knowledge Base

nginx issue during or after Element Software upgrade: Failed to start The nginx HTTP and reverse proxy server

Views:
344
Visibility:
Public
Votes:
0
Category:
element-software
Specialty:
solidfire
Last Updated:

Applies to

  • All models of SolidFire storage nodes.
  • Has been found during upgrades to Element 12.x but may exist in other versions

Issue

  • If this happens during an Element upgrade: On the mNode we will show that it made it through the bulk of the upgrade on a node and then hangs at:

 "PostInstallKexecLoad 87%: Loading kexec kernel".

  • Unable to access the node UI.
  • Unable to send APIs to node, therefore SSH cannot be enabled.
  • If the system's console can be viewed (either locally or via BMC remote control):

      > The following error is displayed during boot:
[FAILED] Failed to start The nginx HTTP and reverse proxy server.
See 'systemctl status nginx.service' for details.

01_error-during-boot.jpg

      > Once the node is fully booted, the following is displayed instead of the normal login screen:
--- Error ---
API server error.  Please fix issues and retry.

02_API-server-error.jpg

  • If the node has been removed from the cluster it will not show up as a "Pending" node for the cluster until this issue is resolved.

 

CUSTOMER EXCLUSIVE CONTENT

Registered NetApp customers get unlimited access to our dynamic Knowledge Base.

New authoritative content is published and updated each day by our team of experts.

Current Customer or Partner?

Sign In for unlimited access

New to NetApp?

Learn more about our award-winning Support