Skip to main content
NetApp Knowledge Base

SnapCenter Plug-in for Oracle non-root install or upgrade fails with an error

Views:
878
Visibility:
Public
Votes:
1
Category:
snapcenter
Specialty:
snapx
Last Updated:

Applies to

  • SnapCenter Plug-in for Oracle (SCO)
  • SnapCenter Plug-in for SAP HANA (SCHANA) on Linux/AIX
  • SnapCenter Creator Plug-ins on Linux/AIX

Issue

When attempting to upgrade or install the SnapCenter Unix based Plug-ins using a non-root user, it fails with one of the following errors:

  • When that account is missing certain entries in sudoers:

Error: sudo: no tty present and no askpass program specified

  • When upgrading from pre-4.4 to 4.4 and higher, bypassing the pre-check, the following error appears:

No Java virtual machine could be found from your PATH environment variable.
You must install a VM prior to running this program.

  • Of, similarly a security message like the following may appear due to version 4.4 or higher updated paths (*):
    We trust you have received the usual lecture from the local System
    

 

Sign in to view the entire content of this KB article.

New to NetApp?

Learn more about our award-winning Support

Scan to view the article on your device