Skip to main content
NetApp Knowledge Base

SVM access fails with secd.unixLookupFailure:error Alerts

Views:
268
Visibility:
Public
Votes:
0
Category:
not set
Specialty:
nas
Last Updated:

Applies to

  • Ontap 9.x
  • Name mapping
  • NAS

Issue

  • Users trying to connect to vServer fails to retrieve the UID and GID and gets below error:
Thu Jun 26 01:40:20 -0400 [vServer: secd: secd.unixLookupFailure:error]: UNIX lookup failure on Vserver (vServer) for client with IP address (xx.xx.xx.xx). 
Error: Acquire UNIX credentials procedure failed   [  1 ms] Entry for group-id: 2003 not found in the current source: FILES. 
Entry for group-id: 2003 not found in any of the available sources **[ 2] FAILURE: Unable to retrieve UNIX groupname for GID 2003
  • The same error can also be observed against IP 0.0.0.0 when ONTAP is trying to resolve the user for its internal operations.

Thu Sep 03 01:59:58 +0900 [cluster-01: secd: secd.unixLookupFailure:error]: UNIXlookup failure on Vserver (svm) for client with IP address (0.0.0.0). 
Error: Acquire UNIX credentials procedure failed 
[ 7 ms] Entry for user-name: user1 not found in the current source: FILES. Entry for user-name: user1 not found in any of the available sources 
**[ 10] FAILURE: Unable to retrieve UID for UNIX user user1

  • Validate in SECD log. Here, when quota creation is attempted but fails because user is not present in nameservice sources, the event failure is reported against 0.0.0.0

Example:

... Thu Sep 03 01:59:58 +0900 ... Worker Thread 34510782720 processing RPC205:secd_rpc_auth_user_name_to_id(caller: MGMT_QUOTA) with request ID:9322 whichsat in the queue for 0 seconds. { in run() atsrc/server/secd_rpc_server.cpp:2477 }

Note: Match timestamp and user to find applicable section in SECD.log and identify the related actions.

  • The symptom here is related to an action initiated by the user user1 as per AUDIT-M log:

00000025.03650fbc 0733faaf Thu Sep 03 2026 01:59:58 +09:00[kern_audit:info:4391] 8003e80001504b25:8003e80001505641 :: Cluster-01:ssh ::10.10.10.1:52900 :: Cluster-01:admin :: volume quota policy rule create -vserversvm1 -policy-name default -volume nfs -type user -target user1 -qtree gold-soft-disk-limit 200MB -disk-limit 201MB :: Error: User name user1 not found.Reason: SecD Error: object not found.

Note: Timestamps, command and username correlate with EMS and SECD log entries.

Sign in to view the entire content of this KB article.

New to NetApp?

Learn more about our award-winning Support

NetApp provides no representations or warranties regarding the accuracy or reliability or serviceability of any information or recommendations provided in this publication or with respect to any results that may be obtained by the use of the information or observance of any recommendations provided herein. The information in this document is distributed AS IS and the use of this information or the implementation of any recommendations or techniques herein is a customer's responsibility and depends on the customer's ability to evaluate and integrate them into the customer's operational environment. This document and the information contained herein may be used solely in connection with the NetApp products discussed in this document.