Skip to main content
NetApp Knowledge Base

All drives in failed state with UnlockFailedNoKey after adding node to cluster

Views:
242
Visibility:
Public
Votes:
4
Category:
element-software
Specialty:
solidfire
Last Updated:

Applies to

  • NetApp Element Software
  • Node added to the cluster with API /json-rpc/8.2?method=AddNodes&pendingNodes=[x]&autoInstall=false

Issue

After node is being added to the cluster:
  • Error in NetApp SolidFire Active IQ
    • Error code: driveFailed
    • Details: 10 drive(s) with state: "UnlockFailedNoKey" driveID: <list of driveIDs>.
  • All drives showing capacity of 0 GB under the (failed) drive list in Active IQ
  • In kern.log the drives are showing I/O errors on sector 0
    • print_req_error: I/O error, dev sd<X>, sector 0
  • When removing the failed drives from the cluster, they re-appear after refreshing the page

Sign in to view the entire content of this KB article.

New to NetApp?

Learn more about our award-winning Support

NetApp provides no representations or warranties regarding the accuracy or reliability or serviceability of any information or recommendations provided in this publication or with respect to any results that may be obtained by the use of the information or observance of any recommendations provided herein. The information in this document is distributed AS IS and the use of this information or the implementation of any recommendations or techniques herein is a customer's responsibility and depends on the customer's ability to evaluate and integrate them into the customer's operational environment. This document and the information contained herein may be used solely in connection with the NetApp products discussed in this document.