Skip to main content
NetApp Knowledge Base

When creating CIFS Server we receive error "Server is unwilling to perform" in ONTAP

Views:
724
Visibility:
Public
Votes:
0
Category:
ontap-9
Specialty:
NAS
Last Updated:

Applies to

  • ONTAP 9
  • CIFS/SMB

Issue

  • When trying to create/setup CIFS server, you get get errors:
    • secd.unexpectedFailure: Unexpected SecD failure in Vserver "svm_VSERVER". Details: Error: Machine account creation procedure failed
        [ 57498] Loaded the preliminary configuration.
        [ 57500] Successfully connected to ip 172.20.17.4, port 88 using TCP
        [ 57533] Successfully connected to ip 172.20.17.4, port 389 using TCP
      **[ 57563] FAILURE: Could not create account 'cn=CVO,CN=Computers,dc=DOMAIN,dc=COM': Server is unwilling to perform
        [ 57563]   Additional info: 00002010: SvcErr: DSID-031A124C, problem 5003 (WILL_NOT_PERFORM), data 0
        [ 57564] Attempt to delete non-existent account ''
        [ 57565] Retry requested, but the retry window (7000 ms) has expired; giving up.
  • Manual attempts to create a computer object in the Domain Controller OU returns the error below:
    • "Windows cannot create the object because the Directory Service was unable to allocate a relative identifier"

 

Sign in to view the entire content of this KB article.

New to NetApp?

Learn more about our award-winning Support

NetApp provides no representations or warranties regarding the accuracy or reliability or serviceability of any information or recommendations provided in this publication or with respect to any results that may be obtained by the use of the information or observance of any recommendations provided herein. The information in this document is distributed AS IS and the use of this information or the implementation of any recommendations or techniques herein is a customer's responsibility and depends on the customer's ability to evaluate and integrate them into the customer's operational environment. This document and the information contained herein may be used solely in connection with the NetApp products discussed in this document.