Unable to modify "storage-efficiency-mode to efficient" on Thick volumes
Applies to
- ONTAP 9
- AFF Systems
Issue
ONTAP reports the following error while changing the efficiency mode or policy on space-guaranteed volumes.
cluster::> volume efficiency modify -vserver svm1 -volume vol10 -storage-efficiency-mode efficient
Error: command failed: Failed to modify efficiency configuration for volume "vol10" of Vserver "svm1": Auto adaptive compression cannot be enabled on space guaranteed volumes.
cluster::> volume efficiency modify -vserver svm1 -volume vol1 -policy inline-only -compression true -inline-compression true -inline-dedupe true -cross-volume-inline-dedupe true -cross-volume-background-dedupe false
Error: command failed: Failed to modify efficiency configuration for volume "vol1" of Vserver "svm1": Auto adaptive compression cannot be enabled on space guaranteed volumes.
