Skip to main content
NetApp Knowledge Base

Cluster-scoped REST endpoint (/api/cluster) against a data SVM FQDN fails with "404 Not Found" error

Views:
48
Visibility:
Public
Votes:
0
Category:
ontap-9
Specialty:
core
Last Updated:

Applies to

  • ONTAP 9
  • REST API

Issue

  • Cluster-scoped REST endpoint (/api/cluster) against a data SVM FQDN fails with "404 Not Found" error:

https://<SVM_FQDN>/api/cluster?return_records=false

"The requested URL was not found on this server"

  • This SVM FQDN resolves to an IP, and the associated LIF has “management- https” service listed, which can be verified from the "network interface show" command output.
  • From "APACHE-ERROR.GZ" logs in the autoupport, during the time of execution failure for this API call, the following messages are observed for vserver SVM1 with vserver ID 34:
[Thu Feb 05 11:00:01.854497 2026 +0000] [dot:error] [pid 83232:tid 34410238976] [client 10.XXX.YY.ZZZ:58740] [vserver ID 34] No web service has resource /api/cluster
[Thu Feb 05 11:00:01.861092 2026 +0000] [dot:error] [pid 83232:tid 34410238976] [client 10.XXX.YY.ZZZ:58750] [vserver ID 34] No web service has resource /api/cluster

Sign in to view the entire content of this KB article.

New to NetApp?

Learn more about our award-winning Support

NetApp provides no representations or warranties regarding the accuracy or reliability or serviceability of any information or recommendations provided in this publication or with respect to any results that may be obtained by the use of the information or observance of any recommendations provided herein. The information in this document is distributed AS IS and the use of this information or the implementation of any recommendations or techniques herein is a customer's responsibility and depends on the customer's ability to evaluate and integrate them into the customer's operational environment. This document and the information contained herein may be used solely in connection with the NetApp products discussed in this document.