Skip to main content
NetApp Knowledge Base

SnapCenter 6.x scheduled backups not running due to RabbitMQ service failing to start

Views:
1,028
Visibility:
Public
Votes:
0
Category:
snapcenter
Specialty:
snapx
Last Updated:

Applies to

  • SnapCenter Server (SC) 6.x
  • RabbitMQ
  • Erlang OTP

Issue

SnapCenter 6.x scheduled backup jobs no longer start / trigger because the RabbitMQ service, which listens for scheduled jobs, fails to start.

The following errors can be seen on the SnapCenter server:

  • SnapCenter UI  >  Dashboard  >  Alerts

RabbitMQ Connection Failure

  • Windows Services when trying to start the RabbitMQ service:

Windows could not start the RabbitMQ service on Local Computer.
Error 1067: The process terminated unexpectedly

  • C:\Program Files\NetApp\SnapCenter WebApp\App_Data\log\SnapManagerWeb.log

ERROR SnapManagerWeb PID=[xxxx] TID=[xx] RabbitMQ broker is unreachable. Retrying in 30 seconds...
DEBUG SnapManagerWeb PID=[xxxx] TID=[xx] AlertBiz Enter CreateAlert
INFO  SnapManagerWeb PID=[xxxx] TID=[xx] MissingTokenInRequest: SMCoreContracts.SmCreateAlertRequest Method: CreateAlert

Sign in to view the entire content of this KB article.

New to NetApp?

Learn more about our award-winning Support

NetApp provides no representations or warranties regarding the accuracy or reliability or serviceability of any information or recommendations provided in this publication or with respect to any results that may be obtained by the use of the information or observance of any recommendations provided herein. The information in this document is distributed AS IS and the use of this information or the implementation of any recommendations or techniques herein is a customer's responsibility and depends on the customer's ability to evaluate and integrate them into the customer's operational environment. This document and the information contained herein may be used solely in connection with the NetApp products discussed in this document.