SnapCenter 6.x scheduled backups not running due to RabbitMQ service failing to start
Applies to
- SnapCenter Server (SC) 6.x
- RabbitMQ
- Erlang OTP
Issue
SnapCenter 6.x scheduled backup jobs no longer start / trigger because the RabbitMQ service, which listens for scheduled jobs, fails to start.
The following errors can be seen on the SnapCenter server:
- SnapCenter UI > Dashboard > Alerts
RabbitMQ Connection Failure
- Windows Services when trying to start the RabbitMQ service:
Windows could not start the RabbitMQ service on Local Computer.
Error 1067: The process terminated unexpectedly
- C:\Program Files\NetApp\SnapCenter WebApp\App_Data\log\SnapManagerWeb.log
ERROR SnapManagerWeb PID=[xxxx] TID=[xx] RabbitMQ broker is unreachable. Retrying in 30 seconds...
DEBUG SnapManagerWeb PID=[xxxx] TID=[xx] AlertBiz Enter CreateAlert
INFO SnapManagerWeb PID=[xxxx] TID=[xx] MissingTokenInRequest: SMCoreContracts.SmCreateAlertRequest Method: CreateAlert
