Skip to main content
NetApp Knowledge Base

NetApp HCI Compute Node Scale fails with network settings error

Views:
403
Visibility:
Public
Votes:
0
Category:
netapp-hci
Specialty:
hci
Last Updated:

Applies to

  • NetApp Deployment Engine (NDE) 1.3.x release
  •  HCI Deployment Engine/Monitoring Agent 

Issue

NetApp HCI  Compute  Node Scale fails with following error :
1086638_1.png

sf-nde.log reports "no hosts found in ESX Cluster on which the compute scale was performed.  

Excerpt from sf-nde.log:

2018-10-12T01:10:09.780607Z | 22709 | 1516248621 | MainProcess-MainThread | inventory_network:606 | INFO | virtual switch type found: VDS
2018-10-12T01:10:09.805160Z | 22709 | 1516248645 | MainProcess-MainThread | inventory_network:338 | INFO | VDS port groups: found 0 HCI port groups out of 4 port groups
2018-10-12T01:10:09.805810Z | 22709 | 1516248646 | MainProcess-MainThread | inventory_network:381 | WARNING | VDS port groups: did not find expected HCI port groups
2018-10-12T01:10:09.806402Z | 22709 | 1516248647 | MainProcess-MainThread | inventory_network:618 | INFO | VDS is not HCI or no HCI VDS portgroups found
2018-10-12T01:10:09.807092Z | 22709 | 1516248647 | MainProcess-MainThread | vmwareutils:343 | DEBUG | Successfully connected
2018-10-12T01:10:11.213744Z | 22709 | 1516250054 | MainProcess-MainThread | inventory_network:197 | WARNING | Did not find HCI VSS portgroups; using existing host network config anyway
2018-10-12T01:10:12.724615Z | 22709 | 1516251565 | MainProcess-MainThread | inventory_network:197 | WARNING | Did not find HCI VSS portgroups; using existing host network config anyway
2018-10-12T01:10:12.728575Z | 22709 | 1516251569 | MainProcess-MainThread | inventory_network:222 | INFO | No HCI host found in cluster: NetApp-HCI-PRD-Cluster-01
2018-10-12T01:10:12.729233Z | 22709 | 1516251569 | MainProcess-MainThread | scale_api:489 | WARNING | No HCI hosts found in requested cluster NetApp-HCI-PRD-Cluster-01
2018-10-12T01:10:12.730404Z | 22709 | 1516251570 | MainProcess-MainThread | app:1560 | ERROR | Exception on /api/2/en_US/scale/inventory/network [GET]
Traceback (most recent call last):
  File "sfprime/scale/scale_api.py", line 481, in get
  File "sfprime/scale/inventory_network.py", line 54, in get_network_info
  File "sfprime/scale/inventory_network.py", line 624, in get_network_info
  File "sfprime/scale/inventory_network.py", line 248, in get_hci_vss_network_topology
sfprime.deploy.errors.ServerError: No HCI hosts found in requested cluster NetApp-HCI-PRD-Cluster-01

 

 

Sign in to view the entire content of this KB article.

New to NetApp?

Learn more about our award-winning Support

NetApp provides no representations or warranties regarding the accuracy or reliability or serviceability of any information or recommendations provided in this publication or with respect to any results that may be obtained by the use of the information or observance of any recommendations provided herein. The information in this document is distributed AS IS and the use of this information or the implementation of any recommendations or techniques herein is a customer's responsibility and depends on the customer's ability to evaluate and integrate them into the customer's operational environment. This document and the information contained herein may be used solely in connection with the NetApp products discussed in this document.