Skip to main content
NetApp Knowledge Base

Default value 'string' in Swagger UI fields causes various problems related to mNode functionality

Views:
826
Visibility:
Public
Votes:
0
Category:
netapp-hci
Specialty:
hci
Last Updated:

Applies to

  • Element Management Node (mNode) version 11.3 and above
  • Swagger UI (REST API) in mNode 11.3 and above
  • Hybrid Cloud Control (HCC)

Issue

The Swagger UI (REST API) at https://<mnode_ip>/mnode can be used for various administrative functions such as updating credentials and adding compute nodes to inventory.

If certain default values are left unedited in the json examples generated by Swagger when submitting changes, various issues can occur downstream in mNode-related functions such as telemetry (reporting cluster data to ActiveIQ) and the display of nodes in HCC.

 

Sign in to view the entire content of this KB article.

New to NetApp?

Learn more about our award-winning Support

NetApp provides no representations or warranties regarding the accuracy or reliability or serviceability of any information or recommendations provided in this publication or with respect to any results that may be obtained by the use of the information or observance of any recommendations provided herein. The information in this document is distributed AS IS and the use of this information or the implementation of any recommendations or techniques herein is a customer's responsibility and depends on the customer's ability to evaluate and integrate them into the customer's operational environment. This document and the information contained herein may be used solely in connection with the NetApp products discussed in this document.
Scan to view the article on your device