Unable to add E-Series data collector to DII due to network issues
Applies to
- NetApp Data Infrastructure Insights (DII)
- NetApp E-Series Storage Arrays
Issue
- When attempting to add E-Series device to the DII monitoring system, the following errors appear in the data collector logs:
E-Series Example Log:
ERROR [com.onaro.sanscreen.acquisition.datasource.engenio_santricity_api.transport.EngenioManagementPath] Could not open address mgxxxxx.axx.int, Connection refused: connectjava.net.ConnectException: Connection refused: connect...ERROR [com.onaro.sanscreen.acquisition.framework.datasource.AuditSession] Failed to connect to device
While adding the collector, using the Test Connection button gives
Configuration: Successfully pinged <controller1_ip>.
Configuration: Successfully pinged <controller2_ip>.
Cannot connect to host - Connection Refuse
- Verify and enable the required network ports between the DII Acquisition Unit and the E-Series :
- E-Series Legacy SANtricity API: TCP 2463
- E-Series REST API: HTTPS 8443
- Confirm connectivity from the DII Acquisition Unit to the management addresses of the target devices using the following tests:
- ping
- nslookup
- port connectivity tests (e.g., Test-NetConnection or telnet) to the required ports
