Unable to deploy Data Broker in Azure from NetApp Console
Applies to
- NetApp NetApp Console Copy and Sync
- Microsoft Azure
Issue
- Unable to deploy the Copy and Sync Data Broker in Azure
- Deployment fails with Azure Active Directory (AAD) error:
invalid_client: AADSTS650057: Invalid resource. The client has requested access to a resource which is not listed in the requested permissions in the client's application registration. Client app ID: {app_id} (CloudSync-CreateDataBroker). Resource value from request: https://management.azure.com. Resource app ID: {resource_app_id}. List of valid resources from app registration: 00000003-0000-0000-c000-000000000000. TraceID: {trace_id} CorrelationID: {correlation_id} Timestamp: 2026-01-02 18:00:00Z
