Skip to main content
NetApp Knowledgebase

Which versions of MySQL are supported by SnapCenter's MySQL Custom Plug-in ?

Views:
62
Visibility:
Public
Votes:
0
Category:
snapcenter
Specialty:
snapx
Last Updated:

Applies to

  • SnapCenter Plug-in for Custom Applications (SCC) 4.x
  • MySQL Plug-in 1.0, 2.0 from the Automation Store

Answer

The following versions are known to work with the MySQL Plug-ins:

  • MySQL 5.1
  • MySQL 5.5
  • MySQL 5.6 and 5.6.20
  • MySQL 5.7 (as used in SnapCenter Server)

If newer versions of MySQL, like 8.0, appear to cause issues, please contact NetApp Support.

Additional Information

Most of these versions come from the Interoperability Matrix Tool (IMT) for Snap Creator Framework (SCF), which has been tested against those versions, and from which the 1.0 Plug-in is derived. The online documentation on the Automation Store does not qualify database version compatibility, with a few exceptions.

Note: support for custom plug-ins on Linux is limited to the Linux releases listed for the SnapCenter Plug-in for Unix (SCU) in the IMT.