Skip to main content
NetApp Knowledge Base

WFA custom workflows start failing after updating the WFA pack for managing ONTAP

Views:
291
Visibility:
Public
Votes:
0
Category:
oncommand-workflow-automation-wfa
Specialty:
om
Last Updated:

Applies to

  • OnCommand Workflow Automation (WFA) 4.2
  • OnCommand Workflow Automation (WFA) 5.0

Issue

The custom workflow fails with a message that the filters have returned no results.

The GUI shows:

Workflow aborted.
No results were found. The following filters have returned empty results:
Filter volumes by key
Location: 'Find Primary Volume' command > 'Volume' tab > 'prod_volume' variable

The server.log from <install_path>\NetApp\WFA\jboss\standalone\log shows that the reservation cannot be saved:

2020-06-29 01:31:03,084 WARNING [org.mariadb.jdbc.internal.mysql.MySQLProtocol] (Thread-3810 (HornetQ-client-global-threads-1468648510)) Could not execute query CALL wfa.reservation_2d12e0c3_6961_471c_a8d8_b76ad6df8bd1(null,null,'cluster_name',null,null,null,null,null,'cluster_name','background',true,'auto','cifs',null,null,'/share_name,null,null,null,null,null,'ntfs',10778,'default',5,'none','online',null,null,'share_name','rw','svm_name'): Column count doesn't match value count at row 1

 

Scan to view the article on your device
CUSTOMER EXCLUSIVE CONTENT

Registered NetApp customers get unlimited access to our dynamic Knowledge Base.

New authoritative content is published and updated each day by our team of experts.

Current Customer or Partner?

Sign In for unlimited access

New to NetApp?

Learn more about our award-winning Support