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Unable to re-key OCI Remote Acquisition Unit password encryption due to mis-matched encryption keys

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114
Visibility:
Public
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0
Category:
oncommand-insight
Specialty:
oci
Last Updated:

Applies to

  • OnCommand Insight (OCI) 7.3.x
  • OnCommand Insight Remote Acquisition Unit (RAU) 7.3.x

Issue

When attempting to re-key the password encryption for OCI or RAU data sources,the RAU re-key procedure fails with error:
Re-Key failed.

Cause

This issue occurs on systems that have had data sources migrated from one RAU or OCI server to another RAU or OCI server.

It occurs because:

  • Each RAU and OCI server has its own password encryption key.
  • When a datasource is migrated to a new RAU or OCI server, it retains the original encryption key.
  • When the re-key is attempted, the re-key fails because the key with which the datasource is encrypted does not match the RAU or OCI server encryption key.

Solution

  1. Navigate to the datasources page: Admin -> Data Sources
  2. Locate a datasource that was migrated to the server
  3. Edit the datasource by right-clicking and selecting Edit, or by clicking the pencil and paper icon on the right.
  4. Update the password for the datasource under the Configuration section.
  5. Save the datasource.
  6. If more than one datasource is migrated, repeat the process for each migrated datasource.
  7. Rerun the securityadmin tool to update the encryption keys.

If there are too many migrated datasources to update the passwords individually, contact NetApp Technical Support for assistance.

 

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