Skip to main content

NetApp_Insight_2020.png 

NetApp Knowledgebase

ONTAP 8.2.X data source failing performance collection with: "Object "system:constituent" was not found."

Views:
16
Visibility:
Public
Votes:
0
Category:
not set
Specialty:
not set
Last Updated:

Applies to

OnCommand Insight 7.3.9

ONTAP Data Source 8.2.X Clustered Mode

Microsoft Windows Server
 

Issue

The following messages might appear in the OnCommand Insight webgui or in the acquisition log files when failing to collect performance data from ONTAP 8.2.X devices.

2020-06-02 05:50:59,734 ERROR [DSM-pool-3-thread-34744] com.onaro.sanscreen.acquisition.framework.datasource.BaseDataSource (DataSourceErrorException.java:186) - NetApp_ONTAP_Storage [Partial Success] - 1 queries failed: Object "system:constituent" was not found. ([Device name ]: 1 queries failed: Object "system:constituent" was not found.)
com.onaro.sanscreen.acquisition.framework.datasource.DataSourceErrorException: 1 queries failed: Object "system:constituent" was not found.


2020-06-02 05:55:08,014 ERROR [DSM-pool-3-thread-34778] com.onaro.sanscreen.acquisition.datasource.netapp_ontap.builder.ClusterBuilder (ClusterBuilder.java:290) - Foundation poll failed to prepare for performance poll: 3 queries failed: Object "workload_queue_nblade" was not found., Object "system:constituent" was not found., Object "resource_headroom_cpu" was not found.

Please note that there are more variations of objects not found not shown. The log lines above doesn't include all possible query errors.

 

CUSTOMER EXCLUSIVE CONTENT

Registered NetApp customers get unlimited access to our dynamic Knowledge Base.

New authoritative content is published and updated each day by our team of experts.

Current Customer or Partner?

Sign In for unlimited access

New to NetApp?

Learn more about our award-winning Support