Skip to main content
NetApp Knowledge Base

After upgrade to OnCommand Workflow Automation 5.1.x the authentication over LDAP does not work anymore

Views:
509
Visibility:
Public
Votes:
0
Category:
oncommand-workflow-automation-wfa
Specialty:
om
Last Updated:

Applies to

  • OnCommand Workflow Automation ( WFA ) 5.1RC1
  • OnCommand Workflow Automation ( WFA ) 5.1
  • OnCommand Workflow Automation ( WFA ) 5.1.1
  • Microsoft Windows Server

Issue

After Upgrading OnCommand Workflow Automation to version 5.1.x the LDAP authentication fails, more specifically LDAP is affected.

  • Error in wfa_ldap.log

2020-03-04 09:40:34,381 ERROR [com.netapp.wfa.ldap.LdapWrapper] (default task-5) Failed to find user in LDAP: javax.naming.CommunicationException: qbitdcp001.operation.lan:636 [Root exception is java.lang.NullPointerException]...

  • Error in wfa.log

2020-03-04 09:40:34,350 WARN  [com.netapp.wfa.common.ssl.SslCertificateUtils] (default task-5) Failed during SSLCertificateUtils:getKeyStore: java.io.EOFException
 at java.base/java.io.DataInputStream.readInt(DataInputStream.java:397)
 at java.base/com.sun.crypto.provider.JceKeyStore.engineLoad(JceKeyStore.java:700)
 at java.base/java.security.KeyStore.load(KeyStore.java:1479)
 at deployment.wfa-0.5.ear.common- .....

 

CUSTOMER EXCLUSIVE CONTENT

Registered NetApp customers get unlimited access to our dynamic Knowledge Base.

New authoritative content is published and updated each day by our team of experts.

Current Customer or Partner?

Sign In for unlimited access

New to NetApp?

Learn more about our award-winning Support