Skip to main content
NetApp Knowledge Base

An OnCommand application service fails to start, with error: "Address already in use"

Views:
347
Visibility:
Public
Votes:
0
Category:
active-iq-unified-manager
Specialty:
om
Last Updated:

Applies to

OnCommand applications

Issue

When starting an OnCommand application service, the service eventually fails to start. Review of the relevant service logs reveals an error stating "Address already in use". The address and port can vary depending on which OnCommand application is being used.

Here is an example of an "Address already in use" socket bind error in Unified Manager. In this example the service is trying to bind to 0.0.0.0:80, but is already in use and bound to by another process, leading to the service failing initialization.

2021-02-17 09:52:00,629 INFO  [org.jboss.as.controller] (Controller Boot Thread) WFLYCTL0183: Service status report
WFLYCTL0184:    New missing/unsatisfied dependencies:
      service jboss.deployment.unit."mega-app.ear".deploymentCompleteService (missing) dependents: [service jboss.deployment.unit."dfm-app.war".PARSE] 
      service jboss.http-upgrade-registry.default (missing) dependents: [service jboss.messaging-activemq.default] 
WFLYCTL0186:   Services which failed to start:      service org.wildfly.undertow.listener.default: Address already in use: bind /0.0.0.0:80

 

Sign in to view the entire content of this KB article.

New to NetApp?

Learn more about our award-winning Support

Scan to view the article on your device