Skip to main content
NetApp Knowledge Base

Why does Trident still use PodSecurityPolicy after Kubernetes has deprecated it ?

Views:
33
Visibility:
Public
Votes:
0
Category:
astra_trident
Specialty:
snapx
Last Updated:

Applies to

  • Trident 21.04 and 21.07
  • Astra Trident 21.10 and higher
  • Kubernetes 1.21 and higher

Answer

The main reason it's still there is backwards compatibility with Kubernetes versions older than 1.21, specifically to still support 1.17.
As long as Trident cannot support 1.25 yet (i.e. until its release), leaving in this compatibility covers more ground.

Additional Information

See Trident Github issue #661 for more information on upcoming changes.
Scan to view the article on your device